Solution to HTTP Error 403.14 - Forbidden

...Your technology solutions posted here
...No dumb rules like "reputation required"
...Share your experience so others can learn
...Feel good about yourself - Positive Karma
Post Reply
User avatar
admin
Site Admin
Posts: 6
Joined: Sat Feb 04, 2017 4:57 pm

Solution to HTTP Error 403.14 - Forbidden

Post: # 62Post admin
Thu Dec 13, 2018 11:18 pm

:?: The Problem :?:
Scroll Down to End of Page for Code Solution

HTTP Error 403.14 - Forbidden
The Web server is configured to not list the contents of this directory.

Most likely causes:
A default document is not configured for the requested URL, and directory browsing is not enabled on the server.

Things you can try:
If you do not want to enable directory browsing, ensure that a default document is configured and that the file exists.
Enable directory browsing.
Go to the IIS Express install directory.
Run appcmd set config /section:system.webServer/directoryBrowse /enabled:true to enable directory browsing at the server level.
Run appcmd set config ["SITE_NAME"] /section:system.webServer/directoryBrowse /enabled:true to enable directory browsing at the site level.
Verify that the configuration/system.webServer/directoryBrowse@enabled attribute is set to true in the site or application configuration file.

Detailed Error Information:
Module DirectoryListingModule
Notification ExecuteRequestHandler
Handler StaticFile
Error Code 0x00000000

:idea: The Solution :idea:

Go to Web.config file of your project.
Add the code to be between the configuration parent tags

Code: Select all

  <system.webServer>
    <directoryBrowse enabled="true" />
    <modules runAllManagedModulesForAllRequests="true" />
  </system.webServer>

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest